ど素人から毛を生やす。<延>

WordPress4.5バージョンアップでHeadSpace2とバッティング

Web > WordPress > プラグイン 2016年4月14日(最終更新:2年前)

2016年4月14日に作成されたページです。
情報が古かったり、僕が今以上のど素人だった頃の記事だったりする可能性があります。

どもです。

ちょうど昨日、WordPress4.5が公開されました。
ので、アップグレードしたのですが、どうにもエディタの調子がおかしい

こういうトラブルは過去にもありました。
だいたいはエディタに変更が加えられたことで、エディタ系プラグインが正常に動かなくなるパターンです。

確かに今回、エディタの機能が一部バージョンアップされているので、この可能性は高い。
が、自分のブログに於いては、エディタ系プラグインなんてAddQuicktagくらいしか使っていません。
こいつがトラブルを起こすなんて聞いたことないですし、実際切っても変わりませんでした。

で、他のプラグインも切ったりつけたりしたところ、HeadSpace2がバッティングしてしまっていることが判明
取り敢えずプラグインの更新があるまではHeadSpace2を切るか、代替を探す方が無難そうです。

追記

エラーの内容は
「Syntax error, unrecognized expression: a[href=#toggle]」

jQueryでのセレクタの書き方が、一定のバージョンからCSSと同じものしか通じなくなっており、
今回のバージョンアップでjQueryのバージョンが上がったことで「そんなセレクタはねーよ」と突っ返されてしまっているようです。

HeadSpace以外でも充分起こりうる不具合なので注意!

この記事は役に立ちましたか?
  • _(:3」∠)_ 面白かった (0)
  • (・∀・) 参考になった (0)
  • (`・ω・´) 役に立った (0)